[Erlang]Cent os 7 安装Erlang

标签: erlang openstack

要安装openstack做测试,少了erlang和wxwidgets,yum无法安装智能手动源码安装了。

1、去官方网站下载源码,openstack要求的是18.3所以下载

wget http://erlang.org/download/otp_src_18.3.tar.gz
tar xzf otp_src_18.3.tar.gz
cd otp_src_18.3
./configure
结果报错,因为要安装openstack的话需要使用最小安装所以系统里面少了很多包,gcc gcc-c++ openssl等等,这个一般都有。

安装以后配置通过,但是还有报错如下

*********************************************************************
**********************  APPLICATIONS DISABLED  **********************
*********************************************************************

crypto         : No usable OpenSSL found
jinterface     : No Java compiler found
odbc           : ODBC library - link check failed
orber          : No C++ compiler found
ssh            : No usable OpenSSL found
ssl            : No usable OpenSSL found

*********************************************************************
*********************************************************************
**********************  APPLICATIONS INFORMATION  *******************
*********************************************************************

wx             : wxWidgets not found, wx will NOT be usable

*********************************************************************
*********************************************************************
**********************  DOCUMENTATION INFORMATION  ******************
*********************************************************************

documentation  : 
                 xsltproc is missing.
                 fop is missing.
                 The documentation can not be built.

*********************************************************************
什么?最重要的wxwidgets竟然没有!!!于是百度了一下,竟然在另一个网站上面需要单独下载

openstack需要的是3.0版所以:

wget https://github.com/wxWidgets/wxWidgets/releases/download/v3.0.2/wxWidgets-3.0.2.tar.bz2
tar xjf wxWidgets-3.0.2.tar.bz2
cd wxWidgets-3.0.2
./configure
恩,然后我发现,centos7的话,直接安装epel源就好了,虽然packstack会自动禁用但是可以先安装Erlang-wx。

略蛋疼,yum解决。



版权所有:《Hoiwan's 》 => 《[Erlang]Cent os 7 安装Erlang
本文地址:http://ihoiwan.com/?post=26
除非注明,文章均为 《Hoiwan's 》 原创,欢迎转载!转载请注明本文地址,谢谢。

评论:

Keyla
2017-07-18 08:35
Obama's election represented the end of America as a project of the European diaspora. Electing Romney isn't going to reverse that or even slow it down. He's one of them. The GOP convention was a pathetic catpiulation to the liberal mindset. In fact, if I were a liberal I'd vote for Romney. Obama's too obvious.

发表评论: